Rough Idle - Honda Pilot - Honda Pilot Forums

Register Home Forums Active Topics Insurance Photo Gallery Garage Search Today's Posts Mark Forums Read Auto Escrow
Piloteers.org is the premier Honda Pilot Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Rate Thread
Old 10-05-2007, 09:22 AM   #1 (permalink)
Registered User
 
Join Date: Jul 2006
Posts: 19
Feedback Score: 0 reviews
Default Rough Idle

Hi -

I looked through the forums for info on rough idle but could not find much. It seems fine wide open and normal driving though. I am going to work on this later today and wanted to see if anyone has seen this before. Mind you, I did replace my EGR valve last year and have been fine. I am going to change the oil, brake fluid, tranny fluid (both) filters (engine and cabin) and prob pull the plugs also to check on them for sh*ts and giggles... and attempt to check the PCV valve and my O2 sensor... The other thing I was thinking about was engine mounts... I think that is a long shot though...
It is a 03 with 48k... I have to say, I do like this car.
In any event, does anyone any suggestions?
Much appreciated!
ducatiduke is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 10-05-2007, 04:34 PM   #2 (permalink)
Registered User
 
Join Date: Jul 2006
Posts: 19
Feedback Score: 0 reviews
Default

Well I am bummed.. 48 folks have viewed this but no comments... Anyone?!?!?!!?
ducatiduke is offline   Reply With Quote
Old 10-05-2007, 08:44 PM   #3 (permalink)
Registered User
 
Medic721's Avatar
 
Join Date: May 2006
Location: Long Island, NY
Posts: 404
Feedback Score: 0 reviews
Send a message via ICQ to Medic721 Send a message via AIM to Medic721 Send a message via Yahoo to Medic721
Default

ok here's my guess. check the throttle body for 'gunk'. If it is gunked up it will not gt the proper amount of air at idle and cause a rough idle. Check first and if it is so, then change the air filter and get some emission safe throttle body cleaner (solvent) and spray it away. My old Jeep had this problem all of the time but my 06 Pilot has been clean.

-Mike.
__________________
2006 EX-L Nav, Billet Silver, Honda Hitch, ATF Cooler, PS Cooler, Honda Towing Harness, Honda Rear Mud Flaps, Catch-All 5 Piece Set, Rear Sub-Frame Kit, Honda Cross Bars, Spare Cup Holder, Factory Service Manuals, ScanGauge II, Softride Pull Pin Bike Rack, Poorman mp3 input, G-Net Navi Video adapter, AirLift 1000 kit.
Medic721 is offline   Reply With Quote
Old 10-05-2007, 08:58 PM   #4 (permalink)
Super Moderator
 
humanoid's Avatar
 
Join Date: Sep 2004
Location: Sunny SoCal
Posts: 3,726
Feedback Score: 0 reviews
Send a message via Yahoo to humanoid
Default

Not sure if the Pilot has one, but maybe check out the idle control valve too, it may need cleaning.
__________________
<------------ click here first, n0oB!!!
humanoid is offline   Reply With Quote
Sponsored Links
Advertisement
 
Reply


Thread Tools
Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -4. The time now is 07:40 AM.



Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO 3.3.2
Garage Plus vBulletin Plugins by Drive Thru Online, Inc.
Copyright 2000 piloteers.org. All Rights Reserved.